Announcements

  • Secure Browser Update - Mac OS

    AIR is now able to support testing for MacOS version 10.14. All field users using MacOS version 10.13 and 10.14 should update their Secure Browser to the latest version of 10.6 for future testing. Users please uninstall the old version of the Secure Browser and install the new version 10.6 by December 31, 2018. After this date, the previous secure browser will no longer be suported for MacOS. Please see the installation link on the Secure Browser page.

    If you need any help with installtion steps access the Secure Browser Installation Manual or call the wyohelpdesk@air.org for support.

    *Note the new browser will work on all versions of MacOS that's supported (10.9+)

    Added November 29, 2018

Key Documents